- Viewpoint Employee Portal Down – Incident details

All systems operational

Viewpoint Employee Portal Down

Resolved
Major outage
Started 9 days agoLasted 7 days

Affected

Apps

Major outage from 2:30 PM to 7:24 PM

Viewpoint

Major outage from 2:30 PM to 7:24 PM

Viewpoint → Viewpoint for Cloud

Major outage from 2:30 PM to 7:24 PM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Identified
    Identified

    A critical case has been logged with Trimble Support. I will update when I know more.

  • Investigating
    Investigating

    I'm looking into this and will update when I know more.