- Microsoft Azure Global Outage – Incident details
All systems operational
Microsoft Azure Global Outage
Resolved
Major outage
Started 9 days agoLasted about 3 hours
Updates
Resolved
Resolved
Our services impacted by this outage have recovered. If anything changes on this, I'll re-open the incident.
Identified
Identified
Microsoft has begun to rollback changes that caused this issue and are beginning to see some services recover. I will update when I know more.
Investigating
Investigating
Microsoft is currently experiencing a global outage of Microsoft Azure services. This is affect Microsoft Admin Portals and some apps & services we use at RO that run on Azure.